Asus UX303U not turning on/battery not charging - Page 3
Page 3 of 3 FirstFirst 123
Results 31 to 34 of 34

Thread: Asus UX303U not turning on/battery not charging

  1. #31
    Join Date
    Feb 2000
    Location
    Idaho Falls, Idaho, USA
    Posts
    17,126
    A 30 day warranty on a motherboard would not give me a lot of confidence that it would last much longer than that. I'd want a year at least.

  2. #32
    Join Date
    Mar 2015
    Posts
    25
    That was my inclination as well. I'm working on finding out the exact make/model spec from the repair guy. Any recommendations for a good place to shop?

  3. #33
    Join Date
    Feb 2000
    Location
    Idaho Falls, Idaho, USA
    Posts
    17,126
    For a replacement motherboard, it would depend on the price. eBay or other vendors might work if the price was low, otherwise it would depend on the warranty terms.

  4. #34
    Join Date
    Feb 2021
    Posts
    1
    I have to put in my $0.02 since I just recently experienced the (known) issue of suddenly not being able to turn on my ASUS UX303UA, and resolved the issue yesterday, no thanks to ASUS. It seems a lot of people are having similar issues with ASUS laptop power. My issue actually seemed to “progress”...a few weeks probably prior to 99% failure, I would have to press and hold the power button for 15 seconds once, twice...a few more times occasionally. Over the course of two weeks, it worsened to not turning on at all...whether plugged in or on battery power. Ultimately, the solution was to reset the CMOS by removing the battery (the main battery; there is no CMOS “watch” battery on this laptop...as I found out is more common these days) and updating the BIOS. I had to do a hard reset (holding down the power button for 45 seconds) about 30 times before I got lucky enough to see the ASUS logo pop up on the screen, and quickly pressed “CTRL-R” to get to the setup screen. Make sure you save the BIOS update file on your thumb drive in the root directory. It will not recognize the file if it is in a folder (the default save option, when you unzip the file from ASUS). For me, it was in FS0. The thumb drive must be plugged in before start up. Once the BIOS was updated, the computer started up like a charm and has worked fine ever since. I have no idea what got corrupted to cause this problem suddenly, but it seems common.

    An important note...I chatted with an ASUS customer service agent, who said he was “researching” the questions that I asked. I specifically asked about the “CMOS battery” and whether or not it could be causing the issue. The ASUS agent replied that “since my warranty expired in 2017, I should have the CMOS battery replaced.” When I asked him if it where it was, he “researched” (consulted a technician? read a generic laptop fix? took a nap and guessed?) and came back to me with “it’s underneath the motherboard.” I then took apart the laptop only to find that NO CMOS battery exists. I have no idea what page ASUS is on with their customer service, but that is an epic FAIL in my book.

    My laptop is working now, thanks to an updated BIOS. If you are starting to experience periodic issues with starting or waking up your ASUS, I recommend updating your BIOS as soon as possible. I was lucky I could still power up mine just to get to the setup screen before it failed completely.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •