"Background" color in MSPaint
Results 1 to 3 of 3

Thread: "Background" color in MSPaint

  1. #1
    Join Date
    Jun 2001
    Location
    Albuquerque, NM USA
    Posts
    14,398

    "Background" color in MSPaint

    A few (not all) of the .gif files I have automatically acquire a blue background when I open them in Paint. (If I open these files in Internet Explorer there is nothing but the graphic, no blue background--so perhaps the native background is either white or transparent.) The effect of this is that, if I open in Paint and make some adjustments to the .gif (like size) and then Save, the saved graphic has the blue background, which I do not want.
    In Paint's toolbar clicking Image|Attributes opens a window that at the bottom under the heading Transparency offers the choice to "Use Transparent Background Color" or to assign a color to the background. Maybe I do not understand what Paint means by Background, but
    1) Before a graphic is loaded into Paint the Transparency part of that window is not active (greyed out)
    2) The Transparency part does activate once the graphic is loaded, but then checking the box "use Transparent Background Color" or changing the color seems to have no effect on the background of the loaded graphic, which has already acquired the blue background. In addition, the color box under Transparency has automatically reverted to blue, even when it was set to white when viewing a previous .gif and/or when the box "Use Transparent Background Color" is checked
    3) At the bottom of the Paint window is the Color Box which is supposed to set the "background" and 'foreground" colors. I can change the foreground color, by clicking on the colors offered, but I cannot make any change to the "background" color.
    Paint's Help does not seem to offer any solutions.
    Does any one have suggestions? Thanks!

    ------------------
    Jim
    WIN98, IE6, cable,
    Norton AV, ZoneAlarm
    Jim
    WIN7 Ultimate SP1 64bit, IE 11, NTFS,
    cable, MS Security Essentials, Windows 7 firewall

  2. #2
    Join Date
    May 2002
    Location
    Scotland
    Posts
    12
    The blue background is set as transparent which explains why you don't see it in IE. If you just want to lose the blue background without doing a manual fill (make a backup of course)...

    1. Load the image and use the "Pick Color" tool to select the background (right-click once).

    2. Left-click white in the palette (or whatever color you want as a new background).

    3. Select All and cut the whole image.

    4. Use the fill tool to paint the blank area white.

    5. Paste the image and make sure you select the "Transparent" icon in the toolbox.

    6. In attributes you can change the transparent color to white or uncheck it.

    [This message has been edited by Leven (edited 05-30-2002).]

  3. #3
    Join Date
    Jun 2001
    Location
    Albuquerque, NM USA
    Posts
    14,398
    Leven--Most kind of you to post suggestions.
    Unfortunately, either I do not understand, or they do not work.
    1) I loaded the image but right clicking on Pick Color does nothing. Left clicking, however, selects it. I did nothing further with the tool until step 4.
    2) I chose white from the palette (I presume you mean the Color Box at the bottom right. BTW--I figured out how to change the "background" color in the Color Box. You simultaneously hold down Control while left clicking.)
    3) I clicked Edit|Select All and then Edit|Cut. That gave me a white box where the graphic had been. (The Paint window is otherwise grey.)
    4) As mentioned, the box where the graphic had been was now blank (white), but to follow your instructions, I moved the "Pick Color" tool over most of it. No changes were apparent since I was painting white on white.
    5) I then used Edit|Paste to paste the graphic. It returned to the blank spot, but still with the blue background. The "Transparent" icon was active in the Tool Box. I tried all the above again, but this time opened a new Paint window to do the pasting. Same result.
    6) In Image|Attributes the "Use transparent..." box was checked and White was chosen as the "Select Color" before doing steps 2-5. I also tried everything with the "Use transparent..." box unchecked. No difference.
    Perhaps you could review the above and tell me where I went wrong?
    Thanks
    P.S. Kind of a Scot to help a Welshman.


    ------------------
    Jim
    WIN98, IE6, cable,
    Norton AV, ZoneAlarm
    Jim
    WIN7 Ultimate SP1 64bit, IE 11, NTFS,
    cable, MS Security Essentials, Windows 7 firewall

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •