USB failed not working anymore
Results 1 to 3 of 3

Thread: USB failed not working anymore

  1. #1
    Join Date
    Dec 2001

    USB failed not working anymore

    All of a sudden my USB device Universal Serial USB has stopped working. I went to Google and followed instructions to uninstall and restart computer. Still no device.
    Using an Asus laptop, Windows 8.
    Message: Unknown USB device (device request failed)
    Windows has stopped this device because it has reported problems (code 43). A request for the UsB device descriptor failed.

    What should I be doing to get the USB to recognize the USB devices?

  2. #2
    Join Date
    Feb 2000
    Idaho Falls, Idaho, USA
    Possibly useful links (if you haven't already seen them:

    If the hardware has actually failed, there is not much you can do. You could try booting from a live Linux disc to see if the USB port(s) are working under Linux. If they aren't then hardware failure is likely.

  3. #3
    Join Date
    Mar 2009
    Arkham Asylum, Cell 13
    Are you talking about Device Manager? Did you remove the device from Device Manager and then allow Windows to redetect it?

    What "instructions" do you mean? Post the link so we know what you tried.

    What is the exact device you are talking about? A flash drive?

    You could also try doing a System Restore to a point where the USB was working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts