Digi camera in usb ... not showing on computor
Results 1 to 5 of 5

Thread: Digi camera in usb ... not showing on computor

  1. #1
    Join Date
    Aug 2003
    Location
    uk
    Posts
    1,002

    Digi camera in usb ... not showing on computor

    Hi
    just plugged a digi camera into my desktop computor but cant see it anywhere

    I ve plugged and unplugged.... switched the camera on and off .... nada ...

    anything else I can try ?

    thanks for help and advice
    Desk Top
    windows home 10
    intel (r) Pentium (r) cpu n3700 @1.60 ghz
    8 GB RAM
    64 BIT OP SYSTEM

  2. #2
    Join Date
    Feb 2000
    Location
    Idaho Falls, Idaho, USA
    Posts
    15,694
    Things to check / try:

    Make sure the camera battery is fully charged

    Check / try different cable

    Try different USB port

    Reboot computer (with camera disconnected)

    Try a different computer

  3. #3
    Join Date
    Aug 2003
    Location
    uk
    Posts
    1,002
    dont really have a diff computor.... except a laptop I rarely use....
    dont have diff cable..

    I rebooted but no luck, I switched camera off then on... I hear a little sound from comp that is sound when something has just got on.... but still the icon does nt appear in ....This PC....
    Desk Top
    windows home 10
    intel (r) Pentium (r) cpu n3700 @1.60 ghz
    8 GB RAM
    64 BIT OP SYSTEM

  4. #4
    Join Date
    Aug 2003
    Location
    uk
    Posts
    1,002
    got my old laptop booted up .... windows 7

    Bingo the camera icon appears... moved the pics onto a litle usb hd
    that way finally got the pics onto my desktop windows 10

    begs the question why is nt windows 10 picking up this Traveller digi camera.....

    granted it is probably 10 plus years old by now !
    Desk Top
    windows home 10
    intel (r) Pentium (r) cpu n3700 @1.60 ghz
    8 GB RAM
    64 BIT OP SYSTEM

  5. #5
    Join Date
    Feb 2000
    Location
    Idaho Falls, Idaho, USA
    Posts
    15,694
    If your Windows 7 laptop sees the camera, then your problem is Windows 10. It may have been helpfully "updating" your USB drivers. You could try the following program to see if the camera is detected. Check Device Manager also.

    https://www.nirsoft.net/utils/usb_devices_view.html

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •