Get rid of read only
Results 1 to 15 of 15

Thread: Get rid of read only

  1. #1
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407

    Get rid of read only

    Inexplicably, entire folders full of files have become read only. After unchecking that box in the Properties, I get a message that I need Admin privs (and I am the Admin) but after Applying the change, the files are back to Read Only.

    It seems that a lot of people are having the problem but I haven't found the cause or the solution.

    What must be done?

    Thanks - rev

  2. #2
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    What folders are you talking about? I suspect you're trying to access old XP style folders. The naming convention changed in Vista and has continued all the way up through Win10. The legacy XP style folders are just junction points, not actual folders. Kind of like shortcuts.

    https://www.svrops.com/svrops/articles/jpoints.htm

  3. #3
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    No, this machine was Win 7 Ult from the beginning and I've been working on the files for months without the slightest problem. Then, all of a sudden, files are read only. I have no idea how they became that way and I found dozens of posts by people having the same trouble on various Windows versions.

    The usual procedure to remove that attribute doesn't work. It appears to work until you try to save the file again, then it's back to read only. I found a workaround which is to save the file to a different format, a .docx to a .doc, for example, and then work with the .doc. When finished, save it back to .docx and all will be well but there might be a large number of files involved so while that method does work, it's not ideal.

  4. #4
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    Hmm, ok. You mean that the files are read-only, not the folder itself?

    What did you try so far? A quick google brought this up:
    https://answers.microsoft.com/en-us/...9-0d23b4196f64
    https://superuser.com/questions/4208...s-in-windows-7

    Did you do any antivirus/antimalware scans?

  5. #5
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    I believe the read only attribute applies only to files not folders but either way, I did nothing to cause this.

    I have not tried the 46 things that didn't work for anyone else. Just Properties, remove attrib, as Admin - which doesn't work.

    I also tried it with an elevated command prompt but I get 'parameter not correct' (the folder is not on the C:\ drive)

  6. #6
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    46 things?

    What is the folder path if it's not the C:\ drive? Can you give us more to go on?

    Did you take ownership of the files first?
    https://www.howtogeek.com/howto/wind...menu-in-vista/

  7. #7
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    Take Ownership is working for me - thanks a lot!

  8. #8
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    Today, Take Ownership no longer works!

  9. #9
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    Bizarre. Did you do AV/Antimalware scans?

    You still didn't give us much else to go on.

  10. #10
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    >Bizarre. Did you do AV/Antimalware scans?
    No.

    >You still didn't give us much else to go on.
    I swear there's nothing to go on. I was working on those files the day before and without virus scanning or new installations of any kind, the whole folder (and others) suddenly became read only. I was only slightly reassured to learn that it's happening to a lot of people but all the obvious solutions don't work.

    Take Ownership was rocking for me yesterday, except I couldn't find a batch method. No biggy, right click and take it from the Context menu. It didn't take me that long but today I'm back where I started and TO isn't working.

    The only thing that is working for me is to save a .docx as a doc, delete the docx and resave the doc as a docx. The result is a read/write file in the latest format - but it's a drag, and I have a lot of files.

  11. #11
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    You said it's not in C:\, so where are the files?

    You said you got a 'parameter not correct' error for attrib, but you didn't post the command you ran.

  12. #12
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    You could also use a utility like BulkFileChanger
    http://www.nirsoft.net/utils/bulk_file_changer.html

  13. #13
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    Here's what I ran but after the error I didn't persevere because this method hadn't worked for other people experiencing the same problem.
    ATTRIB -R D:\Creative Projects\Cross Examination\Docs /S /D

  14. #14
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,144
    If you have spaces in the path, you must put them in quotes. Also you ran the command for the folder, not the files in the folder.

    Try this instead:
    ATTRIB -R "D:\Creative Projects\Cross Examination\Docs\*.*" /S /D

    That's what I meant by giving us something to go on. We can't help you with syntax errors if you don't tell us exactly what you did.

  15. #15
    Join Date
    Jun 2000
    Location
    California
    Posts
    3,407
    I've already fixed them all by saving to a different format but I'll keep that command for tomorrow because I don't think I've seen the end of this and I never found out how it happened. Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •