Portable Hard Drive
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: Portable Hard Drive

  1. #1
    JLS is offline Virtual PC Specialist!!!
    Join Date
    Apr 2002
    Posts
    3,435

    Portable Hard Drive

    I had a WD external portable hard drive connected to my dell xps 13 laptop and was just using it fine. I disconnected the usb cable from my usb hub and reconnected it and now my external drive does not connect. I have other usb devices connected to my usb hub and they all are working fine. I don't see any loose cables associated with my portable drive. What could be the problem? Btw, I am using win 10.

  2. #2
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,231
    Connect to the computer, not to the hub.
    USB only has 500ma available and the hub and stuff maybe drawing to much.

    Now a powered hub, one that plugs into a wall socket too, it has enough power.
    Example:
    https://www.amazon.com/Plugable-port.../dp/B008ZGKWQI

    Yep, even charge your phone.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

  3. #3
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,169
    It has to be a POWERED hub to run USB-powered external hard drives. Obviously if the external hard drive is powered, then it would work fine on a non-powered hub.

  4. #4
    JLS is offline Virtual PC Specialist!!!
    Join Date
    Apr 2002
    Posts
    3,435
    Like I said, I was using this external drive since I got my laptop and was using it earlier today. I am not sure why I can't get it to power on and have it detected on my laptop all of a sudden. What should I do?

  5. #5
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,231
    Unplug everything else, then try it.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

  6. #6
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,169
    You still didn't tell us if it's a powered hub or not. make/model of the hub and external hard drive would give us a better idea of what we're dealing with.

  7. #7
    JLS is offline Virtual PC Specialist!!!
    Join Date
    Apr 2002
    Posts
    3,435
    Midknyte, sorry for the delay in replying back. It is a Belkin usb 2.0 7-port hub F5U237. It does have a power cord because it has led lights on it. The portable drive is a WD MY Book WD7500H1U-00 external drive. I had the WD for some time but rarely used it and only would connect it once it awhile when I could back up my files. The most I've used it has been since I purchased the Dell laptop and was using it a a storage drive the past 2-3 weeks. I have a Rosewill RHB-346 USB 3.0 4-port hub that I had for a bit that I got really inexpensive some time ago that I will probably switch because the Belkin is only usb 2.0 and is old. I am not sure how good Rosewill brand is though. I do see lights pop up inside the WD drive when I first boot up but, then turns off.

  8. #8
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,169
    What happens when you connect directly to a USB port, not using the hub? That drive is not bus-powered, so it should work even on a non-powered hub.

    USB3.0 is much faster than USB 2.0 anyway. I got rid of most of my USB 2.0 stuff, except a couple flash drives I use for UBCD and things like that.

  9. #9
    JLS is offline Virtual PC Specialist!!!
    Join Date
    Apr 2002
    Posts
    3,435
    Midknyte, I tried connecting it to the usb port on my laptop and nothing seems to happen. Like I said, I see the blue lights appear briefly when my laptop first boots up, but, goes out shortly afterwards.

  10. #10
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,169
    Hmm, the drive's controller might be going bad. Did you try it on any other computers?

    If you still can't get the drive to power up, you may need to crack open the case and test the drive with a SATA cable or another external USB hard drive enclosure. At least you'd be able to get the data off that way.

  11. #11
    JLS is offline Virtual PC Specialist!!!
    Join Date
    Apr 2002
    Posts
    3,435
    I hope not being able to retrieve all my data from drive isn't the case. I have been having some bad luck lately and don't need more. I have another one of these WD my book drives that I never opened that I had for a while that I got on clearance few years back. All my data is on that drive. I was going to copy the data to a second back-up drive, but never got around to doing it. I just hope I can get my data or it is going to be a sad time.

    Midknyte, is there an easy way to crack it open, since I am not the most handy?

  12. #12
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,169
    is there an easy way to crack it open, since I am not the most handy?
    No, not really. Those drives aren't made to be opened. You'll probably have to look at a youtube video in order to break open that model.

    https://www.youtube.com/watch?v=-_2oMyoTBno
    https://www.google.com/search?q=wd75...utf-8&oe=utf-8

  13. #13
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,231
    I have swapped power supplies on WD externals and had that work.
    I think what happened was it cleaned the connection as the original did work after that.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

  14. #14
    JLS is offline Virtual PC Specialist!!!
    Join Date
    Apr 2002
    Posts
    3,435
    Train, which power supplies associated with WD externals are you referring?

  15. #15
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,231
    You can cross reference them here
    http://support.wdc.com/knowledgebase...r.aspx?ID=1378

    And they look something like this.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •