[RESOLVED] Toshiba won't turn on
Page 1 of 2 12 LastLast
Results 1 to 15 of 27

Thread: [RESOLVED] Toshiba won't turn on

  1. #1
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237

    Resolved [RESOLVED] Toshiba won't turn on

    Toshiba L75-A7285 laptop with Windows 8.1

    Has been in and out of the computer repair shop about three times as it won't boot up if it's shut down completely. Tech didn't know what else to do with it.

    Have tried taking the battery out, put it back in, been pressing on F2 and F8 with the power button. It just won't show anything on the screen. It's sort of blackish, no logo.

    Last night it was running fine until I had to put some updates in and it shut down afterwards.

    I do have recovery discs but they don't show up either when it's turned on.

    Just any ideas at all? Thank you.
    Smokyieus

  2. #2
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,044
    Remove the battery and try booting up.

    A bad battery will stop things from booting up sometimes.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

  3. #3
    Join Date
    Feb 2000
    Location
    Idaho Falls, Idaho, USA
    Posts
    14,789
    Does the hard drive activity light flicker like it is trying to boot up. If no, then Train's suggestion might help. If yes, then it may be a bad backlight on the screen.

  4. #4
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237
    Took battery out again and tried it. No activity at all. Have two white lights and an orange but no flickers. No beeps either.

    Thanks.
    Smokyieus

  5. #5
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237
    Should have told you that the hard drive was replaced when it was in the shop, did not help this problem.

    Sometimes after it sits a few days it will boot up just fine. Right now, nothing.
    Smokyieus

  6. #6
    Join Date
    Nov 2001
    Location
    some where in the great lakes region
    Posts
    2,934
    I assume you have tried it with power cord

  7. #7
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237
    Yes, thank you.
    Smokyieus

  8. #8
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,053
    Hmm. The only other easy thing to swap would be the AC adapter.

    Does the power port on the laptop wiggle a lot? I've seen a lot of Toshibas where the power socket solder breaks off from the motherboard. I haven't worked on that particular model, though.

  9. #9
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237
    Doesn't seem to move any more than my Toshiba's power. I am helping a friend with the one that won't boot. Seems the tech would have checked all the parts, he came to no conclusion on this.
    Smokyieus

  10. #10
    Join Date
    Nov 2001
    Location
    some where in the great lakes region
    Posts
    2,934
    Last edited by egdufwollamhsram1851; August 1st, 2016 at 12:57 AM.

  11. #11
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237
    Thanks, I have checked those sites before.

    Just an initial diagnosis is $131 - major repair is $390 and I have read they charge $50 or more just to say hello on the phone. Not really worth it for a 3 years old computer.

    My friend has already paid the local tech about $200 and he couldn't solve it.
    Smokyieus

  12. #12
    Join Date
    Feb 2000
    Location
    Idaho Falls, Idaho, USA
    Posts
    14,789
    If you are not getting any activity, and you can't even get into the BIOS setup, and it IS getting power, then you likely have a mainboard hardware issue.

  13. #13
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,044
    Have two white lights and an orange but no flickers
    Hook it up to a monitor. See if you can get anything on it. If yes, then the backlight is a fault.

    $600 would replace it with new one.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

  14. #14
    Join Date
    Apr 2001
    Location
    USA
    Posts
    237
    Ok, when hooked up to a tv via HDMI cable it came on (just on the tv) - got to sign into windows.

    Then the message was "personalized settings not responding" --and tv picture also went grey.

    Computer itself never got off the greyish screen.
    Smokyieus

  15. #15
    Join Date
    Apr 2000
    Location
    Sheboygan, WI
    Posts
    53,044
    OK, the backlight is the problem, and because of all the bad shutdowns, it has messed up windows, a repair install is needed.

    It just might offer that option on the next reboot/bootup. I have not dealt with that model of Toshiba, so I do not know how to force it.

    My friend has already paid the local tech about $200 and he couldn't solve it.
    Does not say much about the tech, except he ripped him off in my book.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

    AntiX-16, MX-16 and Win 10

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •