Phone Not Connecting To PC
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: Phone Not Connecting To PC

  1. #1
    Join Date
    Apr 2008
    Posts
    390

    Phone Not Connecting To PC

    Ever since I've had this smart phone I can't get my PC to full recognize it so I can easily swap files. My PC will charge it.

    The details:

    -I'm using Windows 7 Professional.
    -The phone is a ZTE model Z820 android 5.1
    -Connected by a micro USB to the PC's USB

    When I look in the driver it's plugged into I click "update driver" but I keep getting the same error message on the PC, "Windows found the driver but encountered an error installing it."

    So how can I update the driver or do I need to do something on the phone?

    There's nothing wrong with the USB port as it'll work with other devices.

  2. #2
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,101
    So how can I update the driver or do I need to do something on the phone?
    Did you download the Windows drivers from the manufacturer's site? You should install the drivers BEFORE you connect a USB device.

    Which carrier are you using? You can try looking up your model here:
    https://www.zteusa.com/support_page/

  3. #3
    Join Date
    Apr 2008
    Posts
    390
    Unfortunately that really doesn't help. Try searching for the word "driver" on their ZTE's support site. It's not there.

    Also, Windows said it found the driver but encountered an error when installing it.

  4. #4
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,101
    Did you scroll down and enter your phone model info? Like I said you need to provide your carrier info also.

  5. #5
    Join Date
    Apr 2008
    Posts
    390
    Yes, it took me to my phone model but it only offered me the options of downloading the manual which I did and it does not mention anything about this issue.

    Or "support" where I could ask a question. Which I did.

    I also attempted to Google downloading the diver but none of the android driver updates worked.

    I also went into the phone setting and changed which type of device to connect as, Media Storage, Camera, Charge Only, or CD Rom Drive.

    The only one which changed anything was CD Rom drive, what comes up are three folders, Linux, Mac, Windows and autorun which is a text file.

    In the Windows folder are two icons, AutoRun and Setup. I first tried AutoRun and it said the new driver was installing. But there was no change to the problem.

    Next I tried Setup and it said the driver was already installed. I reinstalled anyway but there was still no change.

    What am I doing wrong?

  6. #6
    Join Date
    Apr 2008
    Posts
    390
    FYI, the phone has successfully connected to other PCs so it's my PC and not the phone which is the problem.

  7. #7
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,101
    Well, you still haven't posted which carrier you're using, so I can't really look it up. Z820 isn't enough. For example, T-Mobile calls the Z820 their "Obsidian" phone.

    https://support.t-mobile.com/docs/DOC-22060

  8. #8
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,101
    One more thing, what type of USB port are you connecting to, USB 2.0 or 3.0? I've seen issues with some phones and USB 3.0 ports.

  9. #9
    Join Date
    Apr 2008
    Posts
    390
    Yes, it's the T Mobile Obsidian.

    It's USB 2.0. Yes, I've tried other cables and other ports with the same results.

    I've seen both T Mobile and ZTE's suggestions. However as I noted, before my connection choices are:

    -Media device
    -Camera
    -Charging only
    -CD Rom Drive

    The first three options only result in charging only. The only one which changed anything was CD Rom drive, what comes up are three folders, Linux, Mac, Windows and autorun which is a text file.

    In the Windows folder are two icons, AutoRun and Setup. I first tried AutoRun and it said the new driver was installing. But there was no change to the problem.

    Next I tried Setup and it said the driver was already installed. I reinstalled anyway but there was still no change.

    I also tried going under Settings to Hotspot and enable Wifi Tethering, again I still could not connect to the phone's files and vice versa.

    FYI, so today at work I tried another test, I walked up to a random Windows 7 PC and connected via USB. It worked just fine and I could transfer files. So the problem is my home PC.

  10. #10
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,101
    Hmm. That is odd.

    Did you look in Device Manager to see if the phone was recognized properly?

    Did you looking Control Panel > Programs and Features to see if the driver software was installed?
    If so, did you try uninstalling and reinstalling the driver software?

    You could also try these drivers instead:
    http://drivers.softpedia.com/get/JOY...-5206616.shtml

  11. #11
    Join Date
    Apr 2008
    Posts
    390
    So I first tried again to update the driver from device manager with the same error message.

    Then I uninstalled the driver. When I reconnected to the USB the PC attempted to install the device but it failed. When I checked for details I found that my setting were set to NEVER install device drivers. "Ah ha!" I thought, that must be the problem. So I changed to "automatically" install device drivers.

    I then went back into device manager and since the driver was uninstalled there was a "trouble shooting" option. But that resulted in a error saying it could not find the driver.

    So I went back to device manager and tried to update the driver. With my install settings changed I figured it might work. Well Windows has been searching for the driver for about an hour and a half now.

    I'll try your link in another hour.

  12. #12
    Join Date
    Apr 2008
    Posts
    390
    Do you have any idea what the read as CD Rom options do? I also tried them and the kept saying successfully installed but without any change.

  13. #13
    Join Date
    Apr 2008
    Posts
    390
    This was the same driver I tried to install yesterday. I attempted to reinstall it with the same results.

  14. #14
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    10,101
    Then I uninstalled the driver. When I reconnected to the USB the PC attempted to install the device but it failed. When I checked for details I found that my setting were set to NEVER install device drivers. "Ah ha!" I thought, that must be the problem. So I changed to "automatically" install device drivers.
    After you uninstalled the drivers, you should have reinstalled them BEFORE connecting to the USB port.

    I'm guessing you mean this:
    https://support.microsoft.com/en-us/kb/2500967

    That's about drivers from Windows Update. That would not affect your ability to install drivers manually.

    I don't have that phone and "CD-ROM" is not a standard Android option. I'm guessing it redirects to a drivers partition on the phone.

  15. #15
    Join Date
    Apr 2008
    Posts
    390
    Alright, so you're suggesting.

    1. Uninstall the driver.
    2. Disconnect USB.
    3. Reinstall the driver. How do I reinstall the driver? Remember, when I go back into Windows and tell it to "update" the driver it'll always fail. Install from your link?
    4. Then reconnect via USB?

    This whole I've been doing these functions always connected via USB as I need it plugged in to tell Windows what to uninstall.
    Last edited by Dollanganger; April 27th, 2016 at 06:35 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •