[RESOLVED] IconCache.db missing
Results 1 to 8 of 8

Thread: [RESOLVED] IconCache.db missing

  1. #1
    Join Date
    May 2001
    Location
    Rosario - Santa Fé - Argentina
    Posts
    599

    Resolved [RESOLVED] IconCache.db missing

    As the icons on my desktop load very slowly, I remembered that a possible solution was to delete the folder IconCache.db.

    To my surprise there is no such folder in my C drive, and I am sure it was there once, as I deleted it.

    On searching for it , I took the precaution of changing folder properties in order to hidden folders to be shown and system protected files not to be hidden.

    I created a folder named IconCache.db on C:\Documents and Settings\Administrador\Application Data and restarted the machine, but the folder remains empty.

    Any ideas ?

    I have XP Pro SP3

  2. #2
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    7,453
    It's not a folder; it's a file.

    You also have the wrong path.
    C:\Documents and Settings\Administrator\Local Settings\Application Data

  3. #3
    Join Date
    May 2001
    Location
    Rosario - Santa Fé - Argentina
    Posts
    599
    No, I had the right path:

    C:\Documents and Settings\Administrador\Configuración local\Application Data

    I copied it wrongly in my post.

    Anyway, now a made a file named IconCache.db, made it read only, restarted, suppressed the read only attribute, restarted again, and the file remains 0 Kb in size.

    I remember seen somewhere that this was a good way to recreate IconCache.db, but it does not work. ( I remembered wrongly that it was a folder )

  4. #4
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    7,453
    you just need to delete the iconcache.db and it will get recreated automatically.

    If that still doesn't work, try this:
    http://smallvoid.com/article/windows-icon-cache.html

  5. #5
    Join Date
    May 2001
    Location
    Rosario - Santa Fé - Argentina
    Posts
    599
    I can not delete IconCache.db because, as I said before, it does not exist in my system.

    Actually, I have deleted it once, long time ago, and as it seems, it was never automatically recreated.

    I will consider your other suggestions.

    Thanks for your input.

  6. #6
    Join Date
    Dec 2000
    Location
    Springfield, OR
    Posts
    2,950
    Ricardo, Try the following. Right click your Desktop, choose Properties, under the Settings tab>Color Quality change the color quality from 32 bit to 16 bit, click Apply/OK. Now go back and change the color quality from 16 bit to 32 bit, click Apply/OK. This will rebuild the IconCache.db file and should restore that file.

    Tufenuf

  7. #7
    Join Date
    May 2001
    Location
    Rosario - Santa Fé - Argentina
    Posts
    599
    Thanks Tufenuf,

    I did what you suggested and, on restarting the machine, as soon as the desktop appeared, the icons were already there.

    An there was a new file IconCache.db 2065 Kb, created on 15/01/2010 at 16.03, but in the folder:

    C:\Documents and Settings\Administrador\Configuración local\Datos de programa

    Instead of:

    C:\Documents and Settings\Administrador\Configuración local\Application Data


    This is because I have the Spanish version of XP. Anyway before this, the file was not in either folder, as I searched for it in the entire drive.

    Thanks again for your simple an effective solution.

  8. #8
    Join Date
    Dec 2000
    Location
    Springfield, OR
    Posts
    2,950
    Ricardo, Glad to see that the problem is corrected and Thanks for posting back to let us know.

    Tufenuf

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •