One of your disks needs to be checked for consistency
Results 1 to 6 of 6

Thread: One of your disks needs to be checked for consistency

  1. #1
    Join Date
    Apr 2005
    Posts
    277

    One of your disks needs to be checked for consistency

    Hi

    I have got two hard disk on my desktop one of them is called C for OS XP SP3 and other is called D for program files and Data

    Recently whenever I restarted my PC I would have been experiencing the message below

    Code:
      Checking file system on D :
      Type : NTFS
       
      One of your disks needs to be checked for consistency. You may cancel the disk check, but it is strongly recommended that you continue.
      
    Windows will now check the disk.
       
      CHKDSK is verifying files (stage 1 of 3)
      File verification completed
       
      CHKDSK is verifying indexes (stage 2 of 3 )
      File verification for completed
       
      CHKDSK is verifying security descriptors (stage 3 of 3 )
      Security descriptors completed
       
       
      After that I could not write the whole message
    What could be causing this problem ?

    Thanks

  2. #2
    Join Date
    Apr 2005
    Location
    USA
    Posts
    16,816
    It could be that the partition is simply marked as 'dirty', which causes CHKDSK to automatically run. Or, it could be a something more serious, like a flaky/failing hard drive.

    The first thing I'd do is run Seagate's "SeaTools for Windows":
    http://www.seagate.com/www/en-us/sup...loads/seatools
    SeaTools for Windows is a comprehensive, easy-to-use diagnostic tool that helps you quickly determine the condition of the disc drive in your external hard drive, desktop or notebook computer. It includes several tests that will examine the physical media on your Seagate or Maxtor disc drive and any other non-Seagate disc drive.

    SeaTools for Windows tests USB, 1394, ATA (PATA/IDE), SATA and SCSI drives. It installs onto your system. SeaTools for Windows is completely data safe.
    If it passes the diags, (and only if it does), run the command "chkdsk d: /r". (Click Start > Run, type in cmd and press [Enter]. At the cmd prompt, type:
    chkdsk d: /r
    and press [Enter]).

    Then reboot and let CHKDSK run.

    Once it's done, reboot once more to see if CHKDSK runs on startup. (It shouldn't).

    Let us know if that did or did not solve the problem and we'll take it from there ...

  3. #3
    Join Date
    Apr 2000
    Location
    Friern Barnet, London, England
    Posts
    46,401
    Go to the Command Prompt (All Programs>Accessories) and type "chkntfs x: /D" without the quotes, where X: is the letter of the drive that you want to check. That will restore the disk checker to its normal behaviour and clear the "dirty bit".

  4. #4
    Join Date
    Apr 2005
    Posts
    277
    Let us know if that did or did not solve the problem and we'll take it from there ...
    Hi SpywareDr

    Beore I have read your reply what I did I followed the instructions in the quote below :

    Please follow the next steps in order:

    Click Start, then Run (Search In Vista)
    Type cmd, and click Ok
    At the prompt in the command window that opens, type fsutil dirty query ?: and press Enter (Where ? is the letter of the drive to queried)

    Does the result of this indicate the drive is "Dirty"?

    To unset the Dirty Bit



    • If you have Spyware Doctor installed, uninstall it.
    • If you have ZoneAlarm installed, open it, click the "Overview" tab, then select "Preferences", and UNcheck the "Protect ZA Client" check box.
    Click Start, then Run, type cmd in the Open box and click "Ok". At the prompt in the Command window, type the following commands, pressing "Enter" after each one:

    Substitute the drive letter for the drive your want to check for the ? in the following commands. Please note the spaces.

    • chkntfs /d ..... (This will reset autocheck options to default...will come back invalid on some installations)
    • chkntfs /c ?: ..... (This will allow checking the specified drive )
    • chkntfs /x ?: ..... (The x switch tells Windows to NOT check the specified drive on the next boot)
    At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.

    This next step is important as this is where the Dirty Bit will be unset.

    Substitute the drive letter for the drive your want to check for the ? in the following commands.

    Click Start, then Run, type cmd in the Open box and click "Ok". At the command prompt, type the following, pressing "Enter" after each one: (Again, note the spaces.)

    • chkdsk /f /r ?: ..... (To manually run a full chkdsk operation on the specified drive)
    • Y ..... (To accept having it run on the next boot)
    This should take you through 5 stages of the scan and will unset the Dirty Bit. Be patient...this is a very thorough check and will take quite a while.

    Finally, when the chkdsk operation has completed, type fsutil dirty query ?:, press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

    Reboot again and see if chkdsk still runs on startup.
    So far so good I restarted the PC three times and chkdsk didn't run on startup

    Let up see how it will go for the next couple of days.

    Thanks
    Last edited by zillah; January 2nd, 2010 at 05:00 PM.

  5. #5
    Join Date
    Mar 2009
    Location
    Arkham Asylum, Cell 13
    Posts
    7,142
    You should still run a hard drive diagnostic. If the drive is failing, you should make a backup ASAP. Don't wait around for a disaster.

  6. #6
    Join Date
    Apr 2005
    Posts
    277
    You should still run a hard drive diagnostic. If the drive is failing, you should make a backup ASAP. Don't wait around for a disaster.
    I will do that and take the backup in a consideration

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •