[RESOLVED] [32] Angry DHCP Client - Error 1075
Results 1 to 7 of 7

Thread: [RESOLVED] [32] Angry DHCP Client - Error 1075

  1. #1
    Join Date
    Jun 2008
    Posts
    3

    Resolved [RESOLVED] [32] Angry DHCP Client - Error 1075

    I cannot get the DHCP Client to run on my Windows Vista Ultimate 32 Bit machine. It is set to start automatically under Services, but it does not start. Also, when I try to start it manually, I get the message:

    Could not start the DHCP Client service on Local Computer.

    Error 1075: The dependency service does not exist or has been marked for deletion.

    I have re-installed Windows Vista Ultimate 32 Bit, but no improvement obtained.

    Any help with this problem will be greatly appreciated.

    Thanks,
    Marc

  2. #2
    Join Date
    Apr 2000
    Location
    Friern Barnet, London, England
    Posts
    46,566


    See if this KB article helps:

    http://support.microsoft.com/kb/915162
    Nick.

  3. #3
    Join Date
    Jun 2008
    Posts
    3
    I have Vista Ultimate running not XP.

  4. #4
    Join Date
    Apr 2000
    Location
    Friern Barnet, London, England
    Posts
    46,566
    Have a look at that registry key anyway, a lot of earlier KB articles still apply. Here's a screenshot of what I have in my Vista Ultimate:
    Nick.

  5. #5
    Join Date
    Jun 2008
    Posts
    3
    I tried it anyway and even though it doesn't have any of the same listings or symptoms? under the heading of DependOnService, I looked at the forum here at Virtual Dr. under Windows XP for another thread with the same problem, and apparently since I used to have Norton at one time, and after an attack from a virus which it was useless to detect, and I have since uninstalled it, (usually something given free with the purchase of your new Dell computer, is usually worth exactly what was paid for it, nothing), it seems to have left something behind under the key DependOnService, and I just deleted it, rebooted, and it seems to have fixed it, so, thank you for pointing me in the right direction, because even though the KB from Microsoft addressed XP, it got me looking for other causes, and found the same thing with another forum member, so again thanks for sending me in the right direction.

  6. #6
    Join Date
    Apr 2000
    Location
    Friern Barnet, London, England
    Posts
    46,566
    You're very welcome, I'm glad you got it sorted out
    Nick.

  7. #7
    Join Date
    Dec 2011
    Posts
    1

    Fixing vista error 1075 -- dhcp service

    Hello all, @onurmarc, thank you for the suggestion. I looked at the Microsoft solution posted above. But for Vista, deleting the registry value "DependOnService" under the key HKLM\System\CurrentControlSet\services\DHCP and rebooting the computer worked instantly to get my internet and ip back. A side note, it also helped the WinHTTP Web Proxy Auto-Discovery Service and probably some other related services get going again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •