Convert 8G USB Drive from FAT32 to NTFS
Results 1 to 11 of 11

Thread: Convert 8G USB Drive from FAT32 to NTFS

  1. #1
    Join Date
    Oct 2000
    Location
    NC
    Posts
    27

    Convert 8G USB Drive from FAT32 to NTFS

    I recently put a 1.4G file on a 8G USB memory drive. Everything transferred over fine but when I took it to another computer it said the folder was empty. When I checked the properties of the drive it said I still had 1.4G used. Anyway, I tried to convert the file system from FAT32 to NTFS using what I have searched on this site. I even formatted the drive completely, checked for errors and deleted everything on the drive and it says "cannot create the elementary file system structure".

    What's the deal? Faulty drive?
    AMD A64 3400+ at 2400MHz, 1.5G DDR, ASUS K8V, RADEON X850XT, Plextor 760A & 716A, Audigy 2 ZS Platinum

  2. #2
    Join Date
    Jul 2004
    Location
    North West England.
    Posts
    9,570
    To enable NTFS on your drive, right click My Computer and select Manage. Open the Device Manager and find your USB drive under the Disk Drives heading. Right click the drive and select Properties, then go to the Policies tab and select the "Optimize for performance" option and Click OK, then do the format, and select NTFS.


    Liam
    Desktop:I5 2500K|Asus P8Z68-V|8GB Corsair Vengeance|1280MB Nvidia 560 TI PE|1TB Seagate/60GB OCZ SSD|LG Blu-ray Writer|Corsair 750W
    27" iMac:I5 2500S|12GB Crucial DDR3|ATI 1GB 6970|1TB|Superdrive|Mighty Mouse

  3. #3
    Join Date
    Oct 2000
    Location
    NC
    Posts
    27
    Thanks.

    I done what you said and it gave me the option to format the drive to ntfs when right clicking the drive and selecting "format". But it said "Windows was unable to complete the format". I also tried the "convert X: /fs:ntfs" method and still didn't work. Anything else to try?

    The drive will format fine when selecting FAT32.
    Last edited by Turbo1dr; August 16th, 2007 at 11:58 PM.
    AMD A64 3400+ at 2400MHz, 1.5G DDR, ASUS K8V, RADEON X850XT, Plextor 760A & 716A, Audigy 2 ZS Platinum

  4. #4
    Join Date
    Apr 2005
    Location
    USA
    Posts
    16,515
    Officially the HP Drive Key Boot Utility is meant for HP disks, but unofficially it seems to work fine at formatting most flash media, even digital camera cards.
    1. Download and install the HP Drive Key Boot Utility

    2. Open the desktop icon and select the correct flash drive under device

    3. Select the file system you want to use: FAT, FAT32, NTFS

    4. Select Quick Format

    5. Click Start

  5. #5
    Join Date
    Oct 2000
    Location
    NC
    Posts
    27
    Quote Originally Posted by SpywareDr
    Officially the HP Drive Key Boot Utility is meant for HP disks,]
    This utility didn't give me any options to format the drive to ntfs. It prepared it as a HP firmware flash device.


    What now?
    AMD A64 3400+ at 2400MHz, 1.5G DDR, ASUS K8V, RADEON X850XT, Plextor 760A & 716A, Audigy 2 ZS Platinum

  6. #6
    Join Date
    Oct 2000
    Location
    NC
    Posts
    27
    Both are Windows XP Pro SP2

    After running the utility above I've now lost half of the drive since FAT32 can only go to 4G's. It now has 4G's that's FAT32 and the other is unallocated.

    I've tried to delete the entire drive in "Disk Management" but no matter what I do it won't let me.

    At this time I'd like to at least get all 8GB's back even if it's FAT32.
    Last edited by Turbo1dr; August 17th, 2007 at 08:49 PM.
    AMD A64 3400+ at 2400MHz, 1.5G DDR, ASUS K8V, RADEON X850XT, Plextor 760A & 716A, Audigy 2 ZS Platinum

  7. #7
    Join Date
    Feb 2000
    Location
    Crystal River, FL. USA
    Posts
    215
    What is the mfg and model of this drive? Have you checked the mfg website? More info please.
    JLN

  8. #8
    Join Date
    Oct 2000
    Location
    NC
    Posts
    27
    I got all the space back on the drive using Active DiskKill for Windows. It's FAT32. This still doesn't solve my issue of having large amounts of data on the drive and Windows says the folder is empty.


    Recap of problem: I had a single folder on this drive with 1.4GB of data in that folder. When I took it to another computer Windows XP Pro said teh folder was empty but really still had the data there.


    It's generic stuff from China.

    Last edited by Turbo1dr; August 17th, 2007 at 09:58 PM.
    AMD A64 3400+ at 2400MHz, 1.5G DDR, ASUS K8V, RADEON X850XT, Plextor 760A & 716A, Audigy 2 ZS Platinum

  9. #9
    Join Date
    Feb 2000
    Location
    Crystal River, FL. USA
    Posts
    215
    It is possible that your system is set to not show hidden files and the file types are considered hidden. What file type are in the folder? Are they from a specific program? The reason I ask is that you said the folder shows empty and that leads me to believe that the system see's the folder but not the files. Am I correct in that assumption?
    JLN

  10. #10
    Join Date
    Apr 2005
    Location
    USA
    Posts
    16,515
    Sorry about all the confusion. I guess the reason I was able to do NTFS was because of the way I had my computer setup. Did some digging and playing around and figured out the "Why?".

    Normally, the only formatting options with a USB-attached drive, (such as a USB key or pen drive), are FAT and/or FAT32. For example, right-click the drive in Windows Explorer and select "Format...". All that you'll usually see is FAT and/or FAT32. Even at the CMD prompt, trying to *force* a NTFS format will result in the following error:
    Code:
    C:\>format m: /fs:ntfs /v:CryptoStick /x
    Insert new disk for drive M:
    and press ENTER when ready...
    NTFS file system is not supported on this device optimized for removal.
    To change the way this device is optimized, select the Policies tab in
    the device's property sheet.
    In order to enable NTFS as a formatting option, you must change the Policies for the device from "Optimize for quick removal" to "Optimize for performance". The NTFS option will then be available in Windows Explorer and at the CMD prompt. For example:
    Code:
    C:\>format m: /fs:ntfs /v:CryptoStick /x
    Insert new disk for drive M:
    and press ENTER when ready...
    The type of the file system is FAT32.
    The new file system is NTFS.
    Verifying 988M
    Volume dismounted.  All opened handles to this volume are now invalid.
    Creating file system structures.
    Format complete.
       1012063 KB total disk space.
       1004617 KB are available.
    To change the Policies, right-click the drive in Windows Explorer and select Properties. Click the Hardware tab, select your USB DISK Device, click the Properties button, then the Policies tab. "Optimize for quick removal" will only allow FAT/FAT32. "Optimize for performance" will add the NTFS option.

  11. #11
    Join Date
    Nov 2007
    Posts
    1

    I'm having tha same problem...

    Hi! I found this discussion on internet and I'm having the same problem... I tried to make the format as you told and I had the error:

    "The secondo NTFS boot sector is Unwritable.
    Format Failed."

    What can I do to solve this?

    Tks.

    Márcio (from Brazil)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •