Cannot open powercfg.cpl
Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Cannot open powercfg.cpl

  1. #1
    Join Date
    Mar 2007
    Posts
    4

    Unhappy Cannot open powercfg.cpl

    Hi

    I cannot open powercfg.cpl
    - I have tried several ways of restoring including:

    One from this site: type "sfc /scannow" which scanned everything and didn't fix it.

    The other was to attempt to copy powercfg.cpl over the original one.

    Even in SAFE mode with DOS the file appears to remain locked for all intents and purposes...

    If I delete it, it restores itself.

    The exact error message is: An exception occured while trying to run "C:\WINDOWS\System32\shell32.dll,Control_RunDLL powercfg.cpl","

    Any ideas?

    Thanks in advance!
    Adam

  2. #2
    Join Date
    Mar 2002
    Location
    At my computer, cruising VDR and watching your back
    Posts
    23,350
    Hi Adam and Welcome to Virtual Dr.

    Did you try right click desktop, select Properties in the list, then select the screen saver tab, click the Power button at the bottom. This should get you to the power control.

    If that doesn't work, go to Start>Run and type powercfg.cpl that also will open power control panel.

    When you ran sfc /scannow did you have your xp cd in the drive also?
    New 8 core
    AMD FX 8350 4Ghz; Gskill 16GB Memory; Kingston 240GB SSD; WD 1TB SATA; Geforce 710 GT 2GB Vid card; Windows 7 Professional 64 bit; HP 25" LED/LCD IPS monitor

    Built by Me, in 2018!!


    UBCD How to Burn an ISO Image to a Disc
    My photos

  3. #3
    Join Date
    Mar 2007
    Posts
    4

    well ...

    I have done/tried right clicking on the screensaver then power option - get the same error - use the start => run - get the same error.

    I don't know if it is a file corruption.

    when I ran the scan it asked for the CD which I put in the drive - it scanned, found nothing, reported nothing and fixed nothing.

    I'm just attempting to run the XP repair wizard :/

    This doesn't seem an easy one to fix even after playing with Windoze for 10 years *sigh*

  4. #4
    Join Date
    Apr 2000
    Location
    Friern Barnet, London, England
    Posts
    46,580
    You'll find a spare copy of Powercfg.cpl in the Windows\System32\dllcache folder. Copy it into Windows\System32 and see if that cures the problem.
    Nick.

  5. #5
    Join Date
    Mar 2007
    Posts
    4

    done but no go

    So tried that they were the same size:

    powercfg.cpl - 112Kb
    powercfg.exe - 48Kb

    Perhaps you can send me yours or I can try with a copy from another windwos XP install?

    meh

  6. #6
    Join Date
    Apr 2000
    Location
    Friern Barnet, London, England
    Posts
    46,580
    Here you go:
    Nick.

  7. #7
    Join Date
    Mar 2007
    Posts
    4

    same thing

    Right I tried that but got the same result - plus the file was the same size and date as mine *sigh*

  8. #8
    Join Date
    Jun 2008
    Posts
    1
    thanks this file
    ım from turkey
    whats up

  9. #9
    Join Date
    Feb 2008
    Posts
    335
    If it worked before on your computer, you might want to reset powermanagement.
    Go to start > Run ,type in: cmd
    This will open a commandbox, at the c:> prompt type:
    powercfg /RestoreDefaultPolicies

    In the BIOS check if APM (Advanced Power Management) is enabled.
    Also in devicemanager (doubleclick computer it should say ACPI computer)

  10. #10
    Join Date
    Jul 2008
    Posts
    1
    Quote Originally Posted by DeP
    If it worked before on your computer, you might want to reset powermanagement.
    Go to start > Run ,type in: cmd
    This will open a commandbox, at the c:> prompt type:
    powercfg /RestoreDefaultPolicies
    Hey, that worked! Thanks! I bet it was some update that my company applied to try to get our laptops to standby more often that screwed up the policies for my machine.

  11. #11
    Join Date
    Jan 2009
    Posts
    1
    Quote Originally Posted by DeP View Post
    If it worked before on your computer, you might want to reset powermanagement.
    Go to start > Run ,type in: cmd
    This will open a commandbox, at the c:> prompt type:
    powercfg /RestoreDefaultPolicies

    In the BIOS check if APM (Advanced Power Management) is enabled.
    Also in devicemanager (doubleclick computer it should say ACPI computer)
    hi bro dis didnt work for my laptop

  12. #12
    Join Date
    Mar 2009
    Location
    Italy
    Posts
    1

    more subtle than that

    Whatever version you have is fine.
    To get rid of any non standard powercfg.cpl alternatives, just go to

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\Power

    and rename the "shellex" subfolder you have there to something funny, such as
    "shellex.NOTHANKS" or "shellex.DISABLED".

    From now on Windows will use its powercfg.cpl instead of your OEM's version.
    Should you revert, just rename the shellex key back.

    Ciao
    Mauro

  13. #13
    Join Date
    Jun 2009
    Posts
    1

    Smile Thanks

    Quote Originally Posted by m2f2 View Post
    Whatever version you have is fine.
    To get rid of any non standard powercfg.cpl alternatives, just go to

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Controls Folder\Power

    and rename the "shellex" subfolder you have there to something funny, such as
    "shellex.NOTHANKS" or "shellex.DISABLED".

    From now on Windows will use its powercfg.cpl instead of your OEM's version.
    Should you revert, just rename the shellex key back.

    Ciao
    Mauro
    Thanks it woked beatiful....

    David E.

  14. #14
    Join Date
    Jun 2009
    Posts
    1

    ;))

    It works for me too! Thx ;D

  15. #15
    Join Date
    Aug 2009
    Posts
    1
    It works for me as well. -Shaun

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •