Help !!! DLL files "open with" notepad????
Results 1 to 10 of 10

Thread: Help !!! DLL files "open with" notepad????

  1. #1
    Join Date
    Jan 2004
    Location
    SHeffield Lake, Ohio
    Posts
    18

    Help !!! DLL files "open with" notepad????

    I used the open with dialog a while back and forgot to "uncheck" the box that says " always use this program to open" and now all my DLL files show open with notepad. Although programs still open I have been getting "Blue screens" shutting down windows and telling me to restart my computer, a lot lately. This started after I carelessly associated dll fils with notepad. I am running Windows XP Home sp2 NTFS. How do I reassociate dll files appropriately? and is this what is causing my "blue screen" problems?
    Share on Google+

  2. #2
    Join Date
    Sep 1999
    Location
    Dallas, Tx.
    Posts
    20,764
    While what you did with notepad was less than good, I doubt it is causing the BSOD. These need to be tackled one at a time. Look in the "Best of XP" thread for the link about BSOD..
    "Life is unpredictable, eat dessert first."
    Share on Google+

  3. #3
    Join Date
    Jan 2004
    Location
    SHeffield Lake, Ohio
    Posts
    18
    Thanks I got the BSOD problem taken care of (i hope) by calling MS and getting a hotfix. What do I do to resolve the dll association problem?
    Share on Google+

  4. #4
    Join Date
    Sep 1999
    Location
    Dallas, Tx.
    Posts
    20,764
    You don't have to do anything. Notepad is as good a choice as any.
    "Life is unpredictable, eat dessert first."
    Share on Google+

  5. #5
    Join Date
    Jul 1998
    Location
    Toronto
    Posts
    21,168
    Basically when a program needs to use or the use of a dll it will use it regardless of what association it has assigned to it. DLLs don't usually get opened by themselves unless you're going to dissect it and look at its code and notepad would be one of the things you could use. Or wordpad or a hex editor etc. So leaving notepad, as Steve says, won't have any effect one way or the other.
    Don't believe everything you think.
    _____________________
    animal lovers click here
    and here
    Share on Google+

  6. #6
    Join Date
    Jun 2001
    Location
    Albuquerque, NM USA
    Posts
    14,545
    Stratcat149--Since there really is no purpose to opening a .dll file, leaving set to Notepad, as has been mentioned, will cause no harm.
    However, if it really bugs you, you can probably get rid of that setting in the Registry. HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt. Now find .dll in the list and click + and then click on the folder named OpenWithList. In the right pane remove Notepad.exe.
    Good idea to back up the registry key first (File|Export) in case something gets fouled up.
    FWIW--My registry shows the default for opening .dll files is iexplore.exe.
    Last edited by Welshjim; January 5th, 2006 at 06:46 PM.
    Jim
    WIN7 Ultimate SP1 64bit, IE 11, NTFS,
    cable, MS Security Essentials, Windows 7 firewall
    Share on Google+

  7. #7
    Join Date
    Jul 2003
    Posts
    1,255
    Quote Originally Posted by Welshjim
    Stratcat149--Since there really is no purpose to opening a .dll file, leaving set to Notepad, as has been mentioned, will cause no harm.
    However, if it really bugs you, you can probably get rid of that setting in the Registry. HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt. Now find .dll in the list and click + and then click on the folder named OpenWithList. In the right pane remove Notepad.exe.
    Good idea to back up the registry key first (File|Export) in case something gets fouled up.
    FWIW--My registry shows the default for opening .dll files is iexplore.exe.
    hmm.., interesting, I thought that it assosiated it using the HKEY_CLASSES_ROOT stuff, but I was wrong

    I wonder why they do it that way instead.., just to complicate things?
    Share on Google+

  8. #8
    Join Date
    Jan 2004
    Location
    SHeffield Lake, Ohio
    Posts
    18
    Thanks all for the excellent feedback. I can rest at ease now that I know I didn't screw things up "too badly".
    Share on Google+

  9. #9
    Join Date
    Feb 2008
    Posts
    2
    if you want to return it back to the original way it was so you know it is a .dll file then go to the path below in registry go to start > run > regedit
    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExt\.dll in there should be a file called (UserChoice) delete the hole file then restart the computer and it should be back to normal
    Share on Google+

  10. #10
    Join Date
    Mar 2002
    Location
    At my computer, cruising VDR and watching your back
    Posts
    21,916
    I would think after two years this OP has found the solution to his problem. Please don't resurrect old posts to post an answer Leonides. This one is now closed.
    New 8 core
    Gigabyte GA-970A- D3 Full ATX Motherboard;AMD FX 8120 3.1Ghz; Corsair Vengeance 16GB Memory; 240GB SSD; 1 TB WD; Geforce GT610 1GB Vid card; Windows 7 Professional 64 bit; Antec Three Hundred Mid tower

    Built by Me!!


    UBCD How to Burn an ISO Image to a Disc
    Share on Google+

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •