Can't Get into Windows 98
Results 1 to 11 of 11

Thread: Can't Get into Windows 98

  1. #1
    Join Date
    Jun 2001
    Location
    Arlington, Texas, USA
    Posts
    5

    Unhappy Can't Get into Windows 98

    I have W98 Full Version. The hardware other than maybe Hard Drive is working Fine. I have put other drives on to check the other hard ware on the PC. My Problem: When I attach my 30 Gig drive and boot up the PC It will show me the startup information. It evens shows the windows 98 logo and then will go and check again and show the W98 logo. Here is where the problem start it will then go back to dos and give me the following error messages: D:\Windows/Sytem vrtwd.386 & Vfixd.vxd.

    Note here: It is showing a "D" Drive when in past it was "C" in the dos mode. With the two error messages.

    I am thinking that something need to be set in the registry but do not know how to get to the registry in dos. It does not allow me to go the the "Safe Mode" as after it sees the second W98 logo it goes directly to dos and shows my "C" drive as "D" with the two error messages.

    I need to know is there a way to get into the registory? and possibly change and what to change? Also what are these 2 error messages. Input and step by step instructions are needed.

    Note: I am using the same PC to do this message without any problems with hardware and I have also checked the bios and everything is okay.

    Can someone give me feed back. But please do give step by step
    instructions.

  2. #2
    Join Date
    May 2002
    Location
    London Ontario Canada
    Posts
    1,335
    I hope you don't have a virus but the files you describe are supposed to be in your Windows/system file. vrtd.386 refers to the Real Time Clock. Both files are virtual device drivers.
    There is a scanreg DOS command found in the windows\command folder
    tiberiuscan

  3. #3
    Join Date
    Apr 2002
    Posts
    1,840
    At the command prompt, type in the following:
    scanreg /restore
    You will get a blue screen program on the screen with five files listed in the middle. These are backup registries. Choose one that is dated before this happened by using the arrow keys. Hit Enter and let it reboot.
    If you have the same files missing and can get into Safe Mode at this point. Click on the Start button and go to Run. Type in SFC then hit Enter or click Ok. When the window named System File Checker opens, click where it says "extract one file from installation disk, then type in the full path of the missing file (C:\Windows/System\Vfixd.vxd), click on start. Now at this point you will need the install CD or have the setup files located on your hard drive, usually C:\Windows\Options\Cabs, if CD D:\Win98 or whichever is your CD drive. Browse to the folder or type in the path, if CD. Then click OK. Since the file is missing, have it skip saving the old file if or when prompted.

    If that is no good, then do this exactly at the command prompt:

    set path=C:\Windows;C:\Windows\Command <Enter>
    cd\windows\system <Enter>
    extract /y c:\windows\options\cabs\win98_54.cab vfixd.vxd <Enter>
    extract /y c:\windows\options\cabs\win98_22.cab vrtwd.386 <Enter>

    This will take those files out for you and put them back. If you do not have those setup files on your hard drive, you will need to have a 98 startup floppy. When booting, choose the option for cd rom support. Then substitute where it says "c:\windows\options\cabs\" with "E:\Win98\", the E being your cdrom drive with the windows install CD. The windows startup disk creates a ramdrive (like a harddrive but exists in your ram) with the drive letter D:, so your cd drive gets bumped a letter.

  4. #4
    Join Date
    Jun 2001
    Location
    Arlington, Texas, USA
    Posts
    5

    More clarification of my W98 Question

    I tried your Suggestions but...

    The reason we know that it is in the registry is because we have tried to restore the files and it keeps looking for them in:

    D:\windows/system

    But we know windows is installed in:

    C:\windows/system

    And the two files are there and have been extracted to there.

    NOTE: There is no windows installed in D: because there is no D: drive. There is only one master Hard Drive.

    When we reboot the computer and the registry goes through it's cycle the registry tells us D:\windows/system. So it can't find the files we extracted to the right folder.

    Any suggestions?

  5. #5
    Join Date
    Apr 2000
    Location
    Elma,Wa.
    Posts
    49,676
    D was the cdrom that you installled from. And is the reason I allways copy the win98 folder from the cd onto the hdd and install from there.
    SMILE
    and post back. Let us know if it worked.
    [ Book mark this post to find it again]

  6. #6
    Join Date
    Apr 2002
    Posts
    1,840
    Here is what you may need to do. Open Notepad and paste these lines between the curly brackets, but don't include them. These must be exact.
    {
    REGEDIT4

    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VRTWD]
    "StaticVxD"="C:\\WINDOWS\\SYSTEM\\vrtwd.386"
    "Start"=hex:00

    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VFIXD]
    "StaticVxD"="C:\\WINDOWS\\SYSTEM\\vfixd.vxd"
    "Start"=hex:00
    }
    Save as under all files as "entries.reg" It must have the .reg extension. It will be called Registration Entries by Windows Explorer. Copy and Paste onto a floppy. Put the floppy into the your computer after it boots up. Then type this in exactly at the command prompt:
    cd\windows
    copy a:\entries.reg c:\
    regedit c:\entries.reg
    If done correctly "Importing file" will appear. Reboot.
    This should change the location in the registry those files should be called from.

  7. #7
    Join Date
    Aug 2001
    Location
    Keizer,Orygun USofA
    Posts
    10,636
    Have you gone into bios and see if the drives are listed correctly? Sounds to me like it's recognizing your CD-ROM(D) as the hard drive. If they are jumpered correctly and installed on the correct board and drive connectors on the IDE cable(s),it may be a recognition problem in bios...
    Stupid question? No such thing!
    Virtual Dr. to the rescue!
    Just ask. Bookmark your post for easy reference.
    ==================================

  8. #8
    Join Date
    Jun 2001
    Location
    Arlington, Texas, USA
    Posts
    5

    To Markp62

    Markp62-[SIZE=1] Tried your Suggestion but the following appears:

    I typed: C:\Windows>regedit c:\entries.reg

    The response was: Unable to open registy (1016)-CMDLINE=regedit C:\entries.reg\WIN.COM

    I am doing this at a DOS prompt as I can't go to any other prompt.

    Am I misunderstanding something?

    So There is no confusion this is that exact messge I get after I boot the machine as I explained in my original question at the top:

    Cannot find a device file that may be needed to run windows or a windows application. The window registry or SYSTEM.INI file refers to this device file, but the device no longer exists. If you deleted this file on purpose, try uninstalling the associated application using it's uninstall or setup program. If you still want to use the application associated with the device file, try reinstalling the application to replace the missing file.

    D:\WINDOWS\SYSTEM\vrtwd.386
    Press key to continue

    NOTE: When I press key to continue I get:

    D:\WINDOWS\SYSTEM\vfixd.vxd
    Press key to continue

    When I do the next message comes up:

    "It's now safe to shutdown your computer"

    We have not deleted anything. We have not installed or uninstalled any applications before this happened. We have replaced the files that windows says it's missing. As you can clearly see as noted above it keeps pointing to D:\ rather than C:\. We feel you are in the right area.

    Everyone seems to be confusing the issue thinking it the CD ROM
    but if you read my two previous replies you will see that this has nothing to do with the CD ROM or the BIOS as this has all been checked. When I move the Hard Drive to another PC the same problem appears.


    (thejourney7@Earthlink.net)

    [COLOR=blue]

  9. #9
    Join Date
    Nov 2001
    Location
    Fishbel
    Posts
    2,412

    Don't you hate when nobody READS the problem description?

    Hmmm... fascinating...

    I have a wacky, zany solution that just might work. Maybe.

    As follows:

    1. Boot to "Command Prompt Only."
    2. Create a directory called wacky off the root of C:
    3. In this directory, create a windows directory, enter THAT directory and create a system directory.
    4. Copy those two "missing" files into c:\wacky\windows\system
    5. Type the command edit c:\autoexec.bat and press enter.
    6. Add the line subst d: c:\wacky to the top.
    7. Chances are the mouse won't be working, just exit the editor by using these three keys in order without holding any down: alt f x


    Now, reboot and go normally-- you may get in this time. Once in, run Regedit and fix those references... a search for those filenames in Regedit would be a good start.

    You may wonder what this all does: Basically, you've created a fake \windows\system directory, but the subst command tells DOS and Windows that this directory exists on the D: drive.

    A long shot, yes. But try it. It can't hurt.
    Welcome to the Eclipse(C). The Evolution of an Idea
    Options: DCM3 LCR VMS CVM Sil CPI VMI ANI 648 CA1 SACD500 Att CID RLS TIME DLG

    Version: ECLIPSE 2.0.0 09/09/98 System is BUSY Thu 07-21-05 1:31 pm
    Access Level = 10 Port = 10

  10. #10
    Nix's Avatar
    Nix is offline Aka: Nix*, NNiixx, Nix23
    Join Date
    May 2001
    Location
    Sydney, Australia
    Posts
    8,255

    Re: Can't Get into Windows 98

    Originally posted by PandaBear
    When I attach my 30 Gig drive and boot up the PC It will show me the startup information. It evens shows the windows 98 logo and then will go and check again and show the W98 logo. Here is where the problem start it will then go back to dos and give me the following error messages: D:\Windows/Sytem vrtwd.386 & Vfixd.vxd
    Have you been playing around with partition's on your 30G drive.

    To me it sounds like you might have a partition C: and a partition D: and the D: is set as the Active partition so it tries to boot off D:.

    If you formatted C: and / or formatted D: using a Win98 boot disk and the /s switch it will put some minimal system files on the drive which would account for the Win98 logo being displayed.

    However I would expect it to stop at DOS prompt nomally if Windows was not installed, so it sounds like something funny going on with your install.

    Try loading with a Win98 bootdisk and then run FDISK and select Y for large hard drive support and select the option to display partition information and write it all down and posy back so we can see if it is something like that.

  11. #11
    Join Date
    Apr 2002
    Posts
    1,840
    You may have partition problems as suggested by Nix, as I am surprised by that error from regedit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •